summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Parks <davep@lindenlab.com>2022-05-04 16:07:50 +0000
committerDave Parks <davep@lindenlab.com>2022-05-04 16:07:50 +0000
commit93260cfeff2382dd1ffeecaef208d37bf21c2a01 (patch)
treea51461dd9f27c27931e2feb288920f7feff71480 /indra/newview/CMakeLists.txt
parent82311e4b44a863078fb1f47d56e9543abaae210c (diff)
SL-17283 LLReflectionMapManager prototype. Remove snapshot code related overhead from reflection map renders. Add parallax correction and support for multiple reflection maps.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 5e50f58595..2bd231bcdc 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -196,7 +196,6 @@ set(viewer_SOURCE_FILES
lldynamictexture.cpp
llemote.cpp
llenvironment.cpp
- llenvironmentmap.cpp
llestateinfomodel.cpp
lleventnotifier.cpp
lleventpoll.cpp
@@ -546,6 +545,8 @@ set(viewer_SOURCE_FILES
llproductinforequest.cpp
llprogressview.cpp
llrecentpeople.cpp
+ llreflectionmap.cpp
+ llreflectionmapmanager.cpp
llregioninfomodel.cpp
llregionposition.cpp
llremoteparcelrequest.cpp
@@ -833,7 +834,6 @@ set(viewer_HEADER_FILES
lldynamictexture.h
llemote.h
llenvironment.h
- llenvironmentmap.h
llestateinfomodel.h
lleventnotifier.h
lleventpoll.h
@@ -1171,6 +1171,8 @@ set(viewer_HEADER_FILES
llproductinforequest.h
llprogressview.h
llrecentpeople.h
+ llreflectionmap.h
+ llreflectionmapmanager.h
llregioninfomodel.h
llregionposition.h
llremoteparcelrequest.h