summaryrefslogtreecommitdiff
path: root/indra/llrender/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Goetze <cg@lindenlab.com>2009-03-13 21:28:40 +0000
committerChristian Goetze <cg@lindenlab.com>2009-03-13 21:28:40 +0000
commit1aa0416aef379bb3ad1012441588b6d7fab81b40 (patch)
tree14a247470bd0d508aba923dc00e940b961d304da /indra/llrender/CMakeLists.txt
parent7573288ab3ede23f97bff2f5caefcb622e7e9842 (diff)
svn merge -r114093:114412 svn+ssh://svn.lindenlab.com/svn/linden/branches/featurettes/featurettes-batch5-merge
Melinda (coco): 5th and final batch of featurettes. My work here is done.
Diffstat (limited to 'indra/llrender/CMakeLists.txt')
-rw-r--r--indra/llrender/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/llrender/CMakeLists.txt b/indra/llrender/CMakeLists.txt
index 72aa3715c0..0bdb55f9d0 100644
--- a/indra/llrender/CMakeLists.txt
+++ b/indra/llrender/CMakeLists.txt
@@ -9,6 +9,8 @@ include(LLImage)
include(LLMath)
include(LLRender)
include(LLWindow)
+include(LLXML)
+include(LLVFS)
include_directories(
${FREETYPE_INCLUDE_DIRS}
@@ -17,12 +19,16 @@ include_directories(
${LLMATH_INCLUDE_DIRS}
${LLRENDER_INCLUDE_DIRS}
${LLWINDOW_INCLUDE_DIRS}
+ ${LLXML_INCLUDE_DIRS}
+ ${LLVFS_INCLUDE_DIRS}
)
set(llrender_SOURCE_FILES
llcubemap.cpp
llfont.cpp
llfontgl.cpp
+ llfontbitmapcache.cpp
+ llfontregistry.cpp
llgldbg.cpp
llglslshader.cpp
llimagegl.cpp
@@ -38,6 +44,8 @@ set(llrender_HEADER_FILES
llcubemap.h
llfontgl.h
llfont.h
+ llfontbitmapcache.h
+ llfontregistry.h
llgl.h
llgldbg.h
llglheaders.h