summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2025-03-06 09:26:21 +0800
committerErik Kundiman <erik@megapahit.org>2025-03-06 09:26:21 +0800
commit5bf93b728ca7c671b6b812e753a40dcdb55b5d0d (patch)
treeab31d87bc2436de8f3e0eeda6d2a6f34438ac6e3 /indra/CMakeLists.txt
parent53197ea0f31270a3094a6720b862bcaeee4851f2 (diff)
parent8c1f00eebc6863c39d0143aeb7e37c68459d454f (diff)
Merge commit '8c1f00eebc6863c39d0143aeb7e37c68459d454f' into 2025.03
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 25570470db..5bf08f63aa 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -33,6 +33,11 @@ else()
set( USE_AUTOBUILD_3P ON )
endif()
+if (NOT DEFINED CMAKE_CXX_STANDARD)
+ set(CMAKE_CXX_STANDARD 20)
+endif()
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
include(Variables)
include(BuildVersion)