summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@gmail.com>2022-04-09 20:15:07 +0200
committerNicky <nicky.dasmijn@gmail.com>2022-04-09 20:15:07 +0200
commit0980a943413dadb0d77f36798f1dd5347994da74 (patch)
treeae420bca313ddec8c0131faf4d78da7ae4048ada /indra/CMakeLists.txt
parent37595f90f9f45efc27409795a9b8c21486518882 (diff)
Bump cmake version needed up to 3.16 so target_precompile_headers can be
used.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 08599b29e0..d06ea58549 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -5,7 +5,8 @@
# with the version specified
## 3.8 added VS_DEBUGGER_WORKING_DIRECTORY support
# 3.13/12 is needed for add_link_options/add_compile_definitions
-cmake_minimum_required(VERSION 3.13.0 FATAL_ERROR)
+# 3.16 is needed for target_precompile_headers
+cmake_minimum_required(VERSION 3.16.0 FATAL_ERROR)
set(ROOT_PROJECT_NAME "SecondLife" CACHE STRING
"The root project/makefile/solution name. Defaults to SecondLife.")