summaryrefslogtreecommitdiff
path: root/indra/viewer_components/login/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/viewer_components/login/CMakeLists.txt')
-rw-r--r--indra/viewer_components/login/CMakeLists.txt22
1 files changed, 13 insertions, 9 deletions
diff --git a/indra/viewer_components/login/CMakeLists.txt b/indra/viewer_components/login/CMakeLists.txt
index fb65779eb7..fe64926da6 100644
--- a/indra/viewer_components/login/CMakeLists.txt
+++ b/indra/viewer_components/login/CMakeLists.txt
@@ -3,7 +3,9 @@
project(login)
include(00-Common)
-include(LLAddBuildTest)
+if(LL_TESTS)
+ include(LLAddBuildTest)
+endif(LL_TESTS)
include(LLCommon)
include(LLMath)
include(LLXML)
@@ -43,14 +45,16 @@ target_link_libraries(lllogin
${PTH_LIBRARIES}
)
-SET(lllogin_TEST_SOURCE_FILES
+if(LL_TESTS)
+ SET(lllogin_TEST_SOURCE_FILES
+ lllogin.cpp
+ )
+
+ set_source_files_properties(
lllogin.cpp
+ PROPERTIES
+ LL_TEST_ADDITIONAL_LIBRARIES "${PTH_LIBRARIES}"
)
-set_source_files_properties(
- lllogin.cpp
- PROPERTIES
- LL_TEST_ADDITIONAL_LIBRARIES "${PTH_LIBRARIES}"
- )
-
-LL_ADD_PROJECT_UNIT_TESTS(lllogin "${lllogin_TEST_SOURCE_FILES}")
+ LL_ADD_PROJECT_UNIT_TESTS(lllogin "${lllogin_TEST_SOURCE_FILES}")
+endif(LL_TESTS)