summaryrefslogtreecommitdiff
path: root/indra/viewer_components/login/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/viewer_components/login/CMakeLists.txt')
-rwxr-xr-xindra/viewer_components/login/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/indra/viewer_components/login/CMakeLists.txt b/indra/viewer_components/login/CMakeLists.txt
index 658f167c2e..6f366677c9 100755
--- a/indra/viewer_components/login/CMakeLists.txt
+++ b/indra/viewer_components/login/CMakeLists.txt
@@ -9,6 +9,7 @@ endif(LL_TESTS)
include(LLCommon)
include(LLMath)
include(LLXML)
+include(Boost)
include_directories(
${LLCOMMON_INCLUDE_DIRS}
@@ -44,12 +45,18 @@ target_link_libraries(lllogin
${LLCOMMON_LIBRARIES}
${LLMATH_LIBRARIES}
${LLXML_LIBRARIES}
+ ${BOOST_CONTEXT_LIBRARY}
)
if(LL_TESTS)
SET(lllogin_TEST_SOURCE_FILES
lllogin.cpp
)
+ set_source_files_properties(
+ lllogin.cpp
+ PROPERTIES
+ LL_TEST_ADDITIONAL_LIBRARIES "${BOOST_CONTEXT_LIBRARY}"
+ )
LL_ADD_PROJECT_UNIT_TESTS(lllogin "${lllogin_TEST_SOURCE_FILES}")
endif(LL_TESTS)