summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 6b15e847a3..8494ba5b49 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -34,6 +34,7 @@ include(LLWindow)
include(NDOF)
include(NVAPI)
include(OPENAL)
+include(OpenEXR)
include(OpenGL)
include(OpenSSL)
include(PNG)
@@ -72,7 +73,6 @@ if (NOT HAVOK_TPV)
endif()
endif (NOT HAVOK_TPV)
-
set(viewer_SOURCE_FILES
groupchatlistener.cpp
llaccountingcostmanager.cpp
@@ -1744,6 +1744,12 @@ if (WINDOWS)
media_plugin_cef
media_plugin_libvlc
media_plugin_example
+ ${SHARED_LIB_STAGING_DIR}/Iex-3_2.dll
+ ${SHARED_LIB_STAGING_DIR}/IlmThread-3_2.dll
+ ${SHARED_LIB_STAGING_DIR}/Imath-3_1.dll
+ ${SHARED_LIB_STAGING_DIR}/OpenEXR-3_2.dll
+ ${SHARED_LIB_STAGING_DIR}/OpenEXRCore-3_2.dll
+ ${SHARED_LIB_STAGING_DIR}/OpenEXRUtil-3_2.dll
)
if (ADDRESS_SIZE EQUAL 64)
@@ -1937,6 +1943,7 @@ target_link_libraries(${VIEWER_BINARY_NAME}
ll::bugsplat
ll::tracy
ll::icu4c
+ ll::openexr
)
if( TARGET ll::intel_memops )