summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 12d452011d..b197182009 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -2229,8 +2229,8 @@ if (LL_TESTS)
set_source_files_properties(
llvocache.cpp
PROPERTIES
- LL_TEST_ADDITIONAL_SOURCE_FILES
- ../llmessage/lldatapacker.cpp
+ LL_TEST_ADDITIONAL_SOURCE_FILES ../llmessage/lldatapacker.cpp
+ LL_TEST_ADDITIONAL_PROJECTS "llprimitive"
)
set(test_libs
@@ -2251,7 +2251,6 @@ if (LL_TESTS)
LL_TEST_ADDITIONAL_LIBRARIES "${test_libs}"
)
-
set_source_files_properties(
llworldmap.cpp
llworldmipmap.cpp
@@ -2271,6 +2270,7 @@ if (LL_TESTS)
PROPERTIES
LL_TEST_ADDITIONAL_SOURCE_FILES llversioninfo.cpp
)
+
set_property( SOURCE
${viewer_TEST_SOURCE_FILES}
PROPERTY