summaryrefslogtreecommitdiff
path: root/indra/media_plugins/libvlc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/media_plugins/libvlc/CMakeLists.txt')
-rw-r--r--indra/media_plugins/libvlc/CMakeLists.txt20
1 files changed, 15 insertions, 5 deletions
diff --git a/indra/media_plugins/libvlc/CMakeLists.txt b/indra/media_plugins/libvlc/CMakeLists.txt
index 535d29125b..d3e9243069 100644
--- a/indra/media_plugins/libvlc/CMakeLists.txt
+++ b/indra/media_plugins/libvlc/CMakeLists.txt
@@ -33,13 +33,13 @@ include_directories(SYSTEM
### media_plugin_libvlc
-if(NOT WORD_SIZE EQUAL 32)
+if(NOT ADDRESS_SIZE EQUAL 32)
if(WINDOWS)
- add_definitions(/FIXED:NO)
+ ##add_definitions(/FIXED:NO)
else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
add_definitions(-fPIC)
endif(WINDOWS)
-endif(NOT WORD_SIZE EQUAL 32)
+endif(NOT ADDRESS_SIZE EQUAL 32)
set(media_plugin_libvlc_SOURCE_FILES
media_plugin_libvlc.cpp
@@ -61,14 +61,24 @@ target_link_libraries(media_plugin_libvlc
add_dependencies(media_plugin_libvlc
${LLPLUGIN_LIBRARIES}
${MEDIA_PLUGIN_BASE_LIBRARIES}
- ${LLCOMMON_LIBRARIES}
+##${LLCOMMON_LIBRARIES}
+ # Just say 'llcommon' here. LLCOMMON_LIBRARIES is specified for use in
+ # target_link_libraries: it includes several Boost libraries, which are
+ # absolutely NOT dependencies in the sense intended here. Those Boost
+ # library macros, in turn, specify 'debug' and 'optimized' and a different
+ # library name for each, producing several wordy errors:
+ # Policy CMP0046 is not set: Error on non-existent dependency in
+ # add_dependencies.
+ # Really, the only dependency we should mention from LLCOMMON_LIBRARIES is
+ # llcommon itself.
+ llcommon
)
if (WINDOWS)
set_target_properties(
media_plugin_libvlc
PROPERTIES
- LINK_FLAGS "/MANIFEST:NO /SAFESEH:NO /LTCG /NODEFAULTLIB:LIBCMT"
+ LINK_FLAGS "/MANIFEST:NO /SAFESEH:NO /NODEFAULTLIB:LIBCMT"
)
endif (WINDOWS)