summaryrefslogtreecommitdiff
path: root/indra/mac_updater/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/mac_updater/CMakeLists.txt')
-rw-r--r--indra/mac_updater/CMakeLists.txt22
1 files changed, 19 insertions, 3 deletions
diff --git a/indra/mac_updater/CMakeLists.txt b/indra/mac_updater/CMakeLists.txt
index 00dcedecaa..7382e912bf 100644
--- a/indra/mac_updater/CMakeLists.txt
+++ b/indra/mac_updater/CMakeLists.txt
@@ -18,10 +18,14 @@ include_directories(
)
set(mac_updater_SOURCE_FILES
+ main.m
+ MacUpdaterAppDelegate.mm
mac_updater.cpp
)
set(mac_updater_HEADER_FILES
+ MacUpdaterAppDelegate.h
+ mac_updater.h
CMakeLists.txt
)
@@ -32,7 +36,7 @@ list(APPEND mac_updater_SOURCE_FILES ${mac_updater_HEADER_FILES})
set(mac_updater_RESOURCE_FILES
- AutoUpdater.nib/
+ AutoUpdater.nib
)
set_source_files_properties(
${mac_updater_RESOURCE_FILES}
@@ -48,13 +52,19 @@ add_executable(mac-updater
set_target_properties(mac-updater
PROPERTIES
- MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist
+ MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/MacUpdater-Info.plist
)
+find_library(COCOA_LIBRARY Cocoa)
+find_library(IOKIT_LIBRARY IOKit)
+
target_link_libraries(mac-updater
${LLVFS_LIBRARIES}
${OPENSSL_LIBRARIES}
${CRYPTO_LIBRARIES}
+ ${COCOA_LIBRARIES}
+ ${BOOST_FILESYSTEM_LIBRARY}
+ ${IOKIT_LIBRARY}
${CURL_LIBRARIES}
${CARES_LIBRARIES}
${LLCOMMON_LIBRARIES}
@@ -62,10 +72,16 @@ target_link_libraries(mac-updater
add_custom_command(
TARGET mac-updater POST_BUILD
+# COMMAND ${CMAKE_COMMAND}
+# ARGS
+# -E
+# copy_directory
+# ${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib
+# ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib
COMMAND ${CMAKE_COMMAND}
ARGS
-E
- copy_directory
+ copy
${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib
${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib
)