summaryrefslogtreecommitdiff
path: root/indra/mac_crash_logger/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/mac_crash_logger/CMakeLists.txt')
-rw-r--r--indra/mac_crash_logger/CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/indra/mac_crash_logger/CMakeLists.txt b/indra/mac_crash_logger/CMakeLists.txt
index 3912595689..daf3e10857 100644
--- a/indra/mac_crash_logger/CMakeLists.txt
+++ b/indra/mac_crash_logger/CMakeLists.txt
@@ -35,7 +35,6 @@ set_source_files_properties(${mac_crash_logger_HEADER_FILES}
list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_HEADER_FILES})
set(mac_crash_logger_RESOURCE_FILES
- Info.plist
CrashReporter.nib/
)
set_source_files_properties(
@@ -43,11 +42,6 @@ set_source_files_properties(
PROPERTIES
HEADER_FILE_ONLY TRUE
)
-set_source_files_properties(
- Info.plist
- PROPERTIES
- MACOSX_PACKAGE_LOCATION . # will it blend? + poppy
- )
SOURCE_GROUP("Resources" FILES ${mac_crash_logger_RESOURCE_FILES})
list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_RESOURCE_FILES})
@@ -55,6 +49,11 @@ add_executable(mac-crash-logger
MACOSX_BUNDLE
${mac_crash_logger_SOURCE_FILES})
+set_target_properties(mac-crash-logger
+ PROPERTIES
+ MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist
+ )
+
target_link_libraries(mac-crash-logger
${LLCRASHLOGGER_LIBRARIES}
${LLVFS_LIBRARIES}