summaryrefslogtreecommitdiff
path: root/indra/lscript/lscript_execute/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/lscript/lscript_execute/CMakeLists.txt')
-rw-r--r--indra/lscript/lscript_execute/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/indra/lscript/lscript_execute/CMakeLists.txt b/indra/lscript/lscript_execute/CMakeLists.txt
new file mode 100644
index 0000000000..f30915bab0
--- /dev/null
+++ b/indra/lscript/lscript_execute/CMakeLists.txt
@@ -0,0 +1,34 @@
+# -*- cmake -*-
+
+include(00-Common)
+include(LLCommon)
+include(LLMath)
+include(LScript)
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ ${LLMATH_INCLUDE_DIRS}
+ ${LSCRIPT_INCLUDE_DIRS}
+ )
+
+set(lscript_execute_SOURCE_FILES
+ lscript_execute.cpp
+ lscript_heapruntime.cpp
+ lscript_readlso.cpp
+ )
+
+set(lscript_execute_HEADER_FILES
+ CMakeLists.txt
+
+ ../lscript_execute.h
+ ../lscript_rt_interface.h
+ lscript_heapruntime.h
+ lscript_readlso.h
+ )
+
+set_source_files_properties(${lscript_execute_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND lscript_execute_SOURCE_FILES ${lscript_execute_HEADER_FILES})
+
+add_library (lscript_execute ${lscript_execute_SOURCE_FILES})