summaryrefslogtreecommitdiff
path: root/indra/llxml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llxml/CMakeLists.txt')
-rw-r--r--indra/llxml/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/indra/llxml/CMakeLists.txt b/indra/llxml/CMakeLists.txt
index 3f7714f505..fbcfade383 100644
--- a/indra/llxml/CMakeLists.txt
+++ b/indra/llxml/CMakeLists.txt
@@ -44,3 +44,25 @@ target_link_libraries( llxml
llmath
${EXPAT_LIBRARIES}
)
+
+# tests
+
+# unit tests
+
+SET(llxml_TEST_SOURCE_FILES
+ # none yet!
+ )
+LL_ADD_PROJECT_UNIT_TESTS(llxml "${llxml_TEST_SOURCE_FILES}")
+
+# integration tests
+
+# set(TEST_DEBUG on)
+set(test_libs
+ ${LLXML_LIBRARIES}
+ ${WINDOWS_LIBRARIES}
+ ${LLMATH_LIBRARIES}
+ ${LLCOMMON_LIBRARIES}
+ )
+
+LL_ADD_INTEGRATION_TEST(llcontrol "" "${test_libs}")
+