summaryrefslogtreecommitdiff
path: root/indra/llplugin/slplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llplugin/slplugin/CMakeLists.txt')
-rw-r--r--indra/llplugin/slplugin/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/indra/llplugin/slplugin/CMakeLists.txt b/indra/llplugin/slplugin/CMakeLists.txt
index 0ea6495eac..e86ddd8a32 100644
--- a/indra/llplugin/slplugin/CMakeLists.txt
+++ b/indra/llplugin/slplugin/CMakeLists.txt
@@ -60,6 +60,15 @@ if (DARWIN)
)
endif (DARWIN)
+if (BUILD_SHARED_LIBS)
+ set_target_properties(SLPlugin PROPERTIES LINK_FLAGS_RELEASE
+ "${LINK_FLAGS_RELEASE} -Wl,--allow-shlib-undefined")
+endif ()
+
+if (INSTALL)
+ install(TARGETS ${PROJECT_NAME} DESTINATION libexec/${VIEWER_BINARY_NAME})
+endif ()
+
if (LL_TESTS)
ll_deploy_sharedlibs_command(SLPlugin)
endif (LL_TESTS)