summaryrefslogtreecommitdiff
path: root/indra/llmessage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llmessage/CMakeLists.txt')
-rw-r--r--indra/llmessage/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/indra/llmessage/CMakeLists.txt b/indra/llmessage/CMakeLists.txt
index 81e518cf6e..4eb4a72ae7 100644
--- a/indra/llmessage/CMakeLists.txt
+++ b/indra/llmessage/CMakeLists.txt
@@ -223,6 +223,23 @@ IF (NOT LINUX AND VIEWER)
lltemplatemessagedispatcher.cpp
llregionpresenceverifier.cpp
)
+# set(TEST_DEBUG on)
+ set(test_libs
+ ${LLMESSAGE_LIBRARIES}
+ ${WINDOWS_LIBRARIES}
+ ${LLVFS_LIBRARIES}
+ ${LLMATH_LIBRARIES}
+ ${LLCOMMON_LIBRARIES}
+ )
+
+ LL_ADD_INTEGRATION_TEST(
+ llsdmessage
+ "llsdmessage.cpp"
+ "${test_libs}"
+ ${PYTHON_EXECUTABLE}
+ "${CMAKE_CURRENT_SOURCE_DIR}/tests/test_llsdmessage_peer.py"
+ )
+
LL_ADD_PROJECT_UNIT_TESTS(llmessage "${llmessage_TEST_SOURCE_FILES}")
# Commented out - see rationale at bottom of newview's build file + poppy 2009-06-05