summaryrefslogtreecommitdiff
path: root/indra/llimage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/llimage/CMakeLists.txt')
-rw-r--r--indra/llimage/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/indra/llimage/CMakeLists.txt b/indra/llimage/CMakeLists.txt
index 79f9565ed9..f1eed409cd 100644
--- a/indra/llimage/CMakeLists.txt
+++ b/indra/llimage/CMakeLists.txt
@@ -67,6 +67,12 @@ target_link_libraries(llimage
ll::libjpeg
)
+if (NOT (USE_AUTOBUILD_3P OR USE_CONAN))
+ if (CMAKE_CXX_COMPILER_ID MATCHES "GNU")
+ set_source_files_properties(llimageworker.cpp PROPERTIES COMPILE_FLAGS -Wno-int-in-bool-context)
+ endif()
+endif ()
+
# Add tests
if (LL_TESTS)
SET(llimage_TEST_SOURCE_FILES