summaryrefslogtreecommitdiff
path: root/indra/llimage/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-12 15:25:59 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-19 11:18:23 +0800
commit43f332459198b40dd11f9c478ca421ab71aec27b (patch)
tree3e15849ecf2359b017a4ca06dafa4acd6bcda312 /indra/llimage/CMakeLists.txt
parent5dddf739f6eae3de351eeb7e5a83ddcc68b31b54 (diff)
Set so int in bool context isn't an error on GCC
and only on a specific file.
Diffstat (limited to 'indra/llimage/CMakeLists.txt')
-rw-r--r--indra/llimage/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/indra/llimage/CMakeLists.txt b/indra/llimage/CMakeLists.txt
index 79f9565ed9..f1eed409cd 100644
--- a/indra/llimage/CMakeLists.txt
+++ b/indra/llimage/CMakeLists.txt
@@ -67,6 +67,12 @@ target_link_libraries(llimage
ll::libjpeg
)
+if (NOT (USE_AUTOBUILD_3P OR USE_CONAN))
+ if (CMAKE_CXX_COMPILER_ID MATCHES "GNU")
+ set_source_files_properties(llimageworker.cpp PROPERTIES COMPILE_FLAGS -Wno-int-in-bool-context)
+ endif()
+endif ()
+
# Add tests
if (LL_TESTS)
SET(llimage_TEST_SOURCE_FILES