summaryrefslogtreecommitdiff
path: root/indra/linux_updater/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/linux_updater/CMakeLists.txt')
-rw-r--r--indra/linux_updater/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/indra/linux_updater/CMakeLists.txt b/indra/linux_updater/CMakeLists.txt
index 4377a6333c..4a9e82f9b6 100644
--- a/indra/linux_updater/CMakeLists.txt
+++ b/indra/linux_updater/CMakeLists.txt
@@ -8,6 +8,7 @@ include(CARes)
include(OpenSSL)
include(UI)
include(LLCommon)
+include(LLMessage)
include(LLVFS)
include(LLXML)
include(LLUI)
@@ -23,6 +24,10 @@ include_directories(
${OPENSSL_INCLUDE_DIRS}
${UI_INCLUDE_DIRS}
)
+include_directories(SYSTEM
+ ${LLCOMMON_SYSTEM_INCLUDE_DIRS}
+ ${LLXML_SYSTEM_INCLUDE_DIRS}
+ )
set(linux_updater_SOURCE_FILES linux_updater.cpp)
@@ -40,6 +45,7 @@ target_link_libraries(linux-updater
${CARES_LIBRARIES}
${OPENSSL_LIBRARIES}
${CRYPTO_LIBRARIES}
+ ${LLMESSAGE_LIBRARIES}
${UI_LIBRARIES}
${LLXML_LIBRARIES}
${LLUI_LIBRARIES}