summaryrefslogtreecommitdiff
path: root/indra/linux_crash_logger/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'indra/linux_crash_logger/CMakeLists.txt')
-rw-r--r--indra/linux_crash_logger/CMakeLists.txt17
1 files changed, 2 insertions, 15 deletions
diff --git a/indra/linux_crash_logger/CMakeLists.txt b/indra/linux_crash_logger/CMakeLists.txt
index a3a4d6be0b..628d4acefc 100644
--- a/indra/linux_crash_logger/CMakeLists.txt
+++ b/indra/linux_crash_logger/CMakeLists.txt
@@ -57,25 +57,12 @@ target_link_libraries(linux-crash-logger
)
add_custom_command(
- OUTPUT linux-crash-logger-stripped-globalsyms
+ OUTPUT linux-crash-logger-stripped
COMMAND strip
- ARGS --strip-debug -o linux-crash-logger-stripped-globalsyms
+ ARGS --strip-debug -o linux-crash-logger-stripped
linux-crash-logger
DEPENDS linux-crash-logger
)
-add_custom_command(
- OUTPUT linux-crash-logger-stripped
- COMMAND objcopy
- ARGS
- --keep-global-symbols
- ${VIEWER_DIR}/newview/linux_tools/exposed-symbols.txt
- linux-crash-logger-stripped-globalsyms
- linux-crash-logger-stripped
- DEPENDS
- linux-crash-logger-stripped-globalsyms
- ${VIEWER_DIR}/newview/linux_tools/exposed-symbols.txt
- )
-
add_custom_target(linux-crash-logger-stripped ALL
DEPENDS linux-crash-logger-stripped)