summaryrefslogtreecommitdiff
path: root/indra/win_updater/CMakeLists.txt
diff options
context:
space:
mode:
authorTofu Linden <tofu.linden@lindenlab.com>2010-04-19 14:30:43 +0100
committerTofu Linden <tofu.linden@lindenlab.com>2010-04-19 14:30:43 +0100
commitb362cc60d9f458626bc69873c5801b3dbd25aae3 (patch)
tree8c59c292a89a0b380e61d5e4f7083240c56192f0 /indra/win_updater/CMakeLists.txt
parentf3d4648ef5c670d519945ca72958e161d5aa12f4 (diff)
parent532d732645f2369d17eba9c2ed0d594b486d416e (diff)
merge from viewer-trunk
Diffstat (limited to 'indra/win_updater/CMakeLists.txt')
-rw-r--r--indra/win_updater/CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/indra/win_updater/CMakeLists.txt b/indra/win_updater/CMakeLists.txt
index 82347adf20..210486c668 100644
--- a/indra/win_updater/CMakeLists.txt
+++ b/indra/win_updater/CMakeLists.txt
@@ -6,6 +6,13 @@ include(00-Common)
include(LLCommon)
include(Linking)
+# *HACK - override msvcrt implementation (intialized on 00-Common) to be
+# statically linked for the installer this relies on vc taking the last flag on
+# the command line
+set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} /MTd")
+set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO} /MT")
+set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} /MT")
+
include_directories(
${LLCOMMON_INCLUDE_DIRS}
)
@@ -30,9 +37,9 @@ target_link_libraries(windows-updater
set_target_properties(windows-updater
PROPERTIES
- LINK_FLAGS "/NODEFAULTLIB:LIBCMT"
- LINK_FLAGS_DEBUG "/NODEFAULTLIB:\"LIBCMT;LIBCMTD;MSVCRT\""
+ LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
+ LINK_FLAGS_DEBUG "/NODEFAULTLIB:\"LIBCMT;MSVCRT\""
)
# The windows-updater doesn't link against anything non-system, apparently
-#ll_deploy_sharedlibs_command(windows-updater) \ No newline at end of file
+#ll_deploy_sharedlibs_command(windows-updater)