summaryrefslogtreecommitdiff
path: root/indra/win_crash_logger/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Kleshchev <andreykproductengine@lindenlab.com>2020-08-11 00:37:14 +0300
committerAndrey Kleshchev <andreykproductengine@lindenlab.com>2020-08-11 00:37:14 +0300
commitb540e9f401c4e63ed6488e49a828829f8b5bfb01 (patch)
treef8ed027616215a58e80b910a0cc0ede1ddd91350 /indra/win_crash_logger/CMakeLists.txt
parent703cbef8ab07db9fe65a39c577377a3e40f63728 (diff)
parent89cde15fb8c52071805af78e61848e743f2ab2f1 (diff)
Merged master into DRTVWR-514-keymappings
Diffstat (limited to 'indra/win_crash_logger/CMakeLists.txt')
-rw-r--r--indra/win_crash_logger/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/indra/win_crash_logger/CMakeLists.txt b/indra/win_crash_logger/CMakeLists.txt
index 4fba26ab2f..86aa655f03 100644
--- a/indra/win_crash_logger/CMakeLists.txt
+++ b/indra/win_crash_logger/CMakeLists.txt
@@ -68,11 +68,11 @@ list(APPEND
${win_crash_logger_RESOURCE_FILES}
)
-find_library(DXGUID_LIBRARY dxguid ${DIRECTX_LIBRARY_DIR})
-
add_executable(windows-crash-logger WIN32 ${win_crash_logger_SOURCE_FILES})
+
target_link_libraries(windows-crash-logger
+ ${LEGACY_STDIO_LIBS}
${BREAKPAD_EXCEPTION_HANDLER_LIBRARIES}
${LLCRASHLOGGER_LIBRARIES}
${LLWINDOW_LIBRARIES}
@@ -83,9 +83,9 @@ target_link_libraries(windows-crash-logger
${LLCOREHTTP_LIBRARIES}
${LLCOMMON_LIBRARIES}
${BOOST_CONTEXT_LIBRARY}
- ${BOOST_COROUTINE_LIBRARY}
+ ${BOOST_FIBER_LIBRARY}
${WINDOWS_LIBRARIES}
- ${DXGUID_LIBRARY}
+ dxguid
${GOOGLE_PERFTOOLS_LIBRARIES}
user32
gdi32