summaryrefslogtreecommitdiff
path: root/indra/viewer_components/updater/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew A. de Laix <alain@lindenlab.com>2010-11-02 15:59:10 -0700
committerAndrew A. de Laix <alain@lindenlab.com>2010-11-02 15:59:10 -0700
commitbe151807222ffa5972256aa9a392e8a319eae5ee (patch)
treec49ffe17811a5841bb8ad7f2e30f45e06adb2b4f /indra/viewer_components/updater/CMakeLists.txt
parent36b8b88153180f637c24709dc94739b5f4c4367e (diff)
start of the downloader service.
Diffstat (limited to 'indra/viewer_components/updater/CMakeLists.txt')
-rw-r--r--indra/viewer_components/updater/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/viewer_components/updater/CMakeLists.txt b/indra/viewer_components/updater/CMakeLists.txt
index 2e77a7140a..64a0f98c2a 100644
--- a/indra/viewer_components/updater/CMakeLists.txt
+++ b/indra/viewer_components/updater/CMakeLists.txt
@@ -6,24 +6,30 @@ include(00-Common)
if(LL_TESTS)
include(LLAddBuildTest)
endif(LL_TESTS)
+include(CURL)
include(LLCommon)
include(LLMessage)
include(LLPlugin)
+include(LLVFS)
include_directories(
${LLCOMMON_INCLUDE_DIRS}
${LLMESSAGE_INCLUDE_DIRS}
${LLPLUGIN_INCLUDE_DIRS}
+ ${LLVFS_INCLUDE_DIRS}
+ ${CURL_INCLUDE_DIRS}
)
set(updater_service_SOURCE_FILES
llupdaterservice.cpp
llupdatechecker.cpp
+ llupdatedownloader.cpp
)
set(updater_service_HEADER_FILES
llupdaterservice.h
llupdatechecker.h
+ llupdatedownloader.h
)
set_source_files_properties(${updater_service_HEADER_FILES}
@@ -42,6 +48,8 @@ target_link_libraries(llupdaterservice
${LLCOMMON_LIBRARIES}
${LLMESSAGE_LIBRARIES}
${LLPLUGIN_LIBRARIES}
+ ${LLVFS_LIBRARIES}
+ ${CURL_LIBRARIES}
)
if(LL_TESTS)