summaryrefslogtreecommitdiff
path: root/indra/test/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2019-03-02 11:58:11 -0500
committerOz Linden <oz@lindenlab.com>2019-03-02 11:58:11 -0500
commite409c0492f1b1ce63606c0b693c92cdb36dcc28b (patch)
tree1b74701425dad859b4eb8e01593af79848dc323c /indra/test/CMakeLists.txt
parentfc90cad4f366c4bb85add832a2fa8137b1f120ff (diff)
convert to an explicit USE_BUGSPLAT switch in cmake, revise LL_ERRS approach
Diffstat (limited to 'indra/test/CMakeLists.txt')
-rw-r--r--indra/test/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/indra/test/CMakeLists.txt b/indra/test/CMakeLists.txt
index 8344cead57..7ac1f1db23 100644
--- a/indra/test/CMakeLists.txt
+++ b/indra/test/CMakeLists.txt
@@ -13,7 +13,7 @@ include(LLXML)
include(Linking)
include(Tut)
include(LLAddBuildTest)
-
+include(bugsplat)
include(GoogleMock)
include_directories(
@@ -82,6 +82,10 @@ list(APPEND test_SOURCE_FILES ${test_HEADER_FILES})
add_executable(lltest ${test_SOURCE_FILES})
+if (USE_BUGSPLAT)
+ set_target_properties(lltest PROPERTIES COMPILE_DEFINITIONS "${BUGSPLAT_DEFINE}")
+endif (USE_BUGSPLAT)
+
target_link_libraries(lltest
${LLDATABASE_LIBRARIES}
${LLINVENTORY_LIBRARIES}