summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2011-08-08 23:23:58 -0400
committerOz Linden <oz@lindenlab.com>2011-08-08 23:23:58 -0400
commitf8a2b67649416267cf86d4ff4568e59cdbaaa5c7 (patch)
tree8bf5c84b6f7f95c449942a3ddff8b536f0952a1e /indra/newview/CMakeLists.txt
parent1d0575bcc4d2740dc4b6e7009b6788ac88744eb5 (diff)
parent881a215535d7bd3b9efc55b9f36722ceec4ccef1 (diff)
merge changes for storm-1060
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 86fbc248b0..7e1d46f0e8 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1253,10 +1253,13 @@ if (WINDOWS)
endif(USE_PRECOMPILED_HEADERS)
# Replace the icons with the appropriate ones for the channel
+ # ('test' is the default)
set(ICON_PATH "test")
string(TOLOWER ${VIEWER_CHANNEL} channel_lower)
- if(channel_lower MATCHES "^(release|beta|development)")
+ if(channel_lower MATCHES "^(release|development)")
set(ICON_PATH ${channel_lower})
+ elseif(channel_lower MATCHES "^(beta.*)")
+ set(ICON_PATH "beta")
elseif(channel_lower MATCHES "^(project.*)")
set(ICON_PATH "project")
endif()