summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@gmail.com>2022-04-16 17:20:16 +0200
committerNicky <nicky.dasmijn@gmail.com>2022-04-16 17:20:16 +0200
commitf673b958fe36b19e999ab881255006d1d1d94bc0 (patch)
tree4edf1698e67c0138caff006d7aa962c0179ed0cb /indra/newview/CMakeLists.txt
parent5803625db552900fd54c248c1f41e2f04bf66d62 (diff)
Go back to more modern way to compile the physics stub
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 9af6ddcca6..500794bab1 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -57,14 +57,12 @@ if (NOT HAVOK_TPV)
# which includes a CMakeList.txt and then this whole source tree gets pushed into out build ... :/
# To make matters worse there is a internal assumption about the structure of the viewers CMake layout,
# which means we need to duct tape this togther ...
- get_property( LLCOMMON_INCLUDE_DIRS TARGET llcommon PROPERTY INTERFACE_INCLUDE_DIRECTORIES )
- get_property( LLMATH_INCLUDE_DIRS TARGET llmath PROPERTY INTERFACE_INCLUDE_DIRECTORIES )
add_subdirectory(${LLPHYSICSEXTENSIONS_SRC_DIR} llphysicsextensions)
# Another hack that works with newer cmake versions:
- #cmake_policy( SET CMP0079 NEW)
- #target_link_libraries(llphysicsextensionsstub llcommon llmath)
+ cmake_policy( SET CMP0079 NEW)
+ target_link_libraries(llphysicsextensionsstub llcommon llmath)
endif (NOT HAVOK_TPV)