summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-12 11:56:03 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-19 10:56:57 +0800
commitf4c8949ac66d08263845f60a7cef2ecb9c77079b (patch)
treee871bc7a90bc3f222ddb768b7ba79c0245f49961 /indra/newview/CMakeLists.txt
parentb0f295ec2a2fd448bb248befb5b57b26b6144332 (diff)
VLC & CEF aren't deps when no media plugins on mac
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index d3de5b9375..b24f643929 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -2069,7 +2069,11 @@ if (DARWIN)
${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
)
+ if (ENABLE_MEDIA_PLUGINS)
add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_libvlc media_plugin_cef)
+ else ()
+ add_dependencies(${VIEWER_BINARY_NAME} SLPlugin)
+ endif ()
if (ENABLE_SIGNING)
set(SIGNING_SETTING "--signature=${SIGNING_IDENTITY}")