summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2024-05-18 17:36:51 +0800
committerErik Kundiman <erik@megapahit.org>2024-05-18 17:36:51 +0800
commitf05e098cbf9e6e89bdb59eadc809cb7cfb7d3c49 (patch)
treee1c116dc7bc037d4d858a62ac6f457f93df5bca6 /indra/newview/CMakeLists.txt
parenteea819032cfb41758bbe2ce37e7417a0333ef9e2 (diff)
Less strictness with Fedora's GCC 14
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 8e19e00da7..c82124575c 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1983,12 +1983,24 @@ elseif (CMAKE_CXX_COMPILER_ID MATCHES "GNU")
llpanelface.cpp
lltexturefetch.cpp
PROPERTIES COMPILE_FLAGS -Wno-maybe-uninitialized)
+ set_source_files_properties(llfasttimerview.cpp PROPERTIES
+ COMPILE_FLAGS -Wno-nonnull)
set_source_files_properties(llinventorygallerymenu.cpp PROPERTIES
COMPILE_FLAGS -Wno-uninitialized)
set_source_files_properties(llviewerstats.cpp PROPERTIES
COMPILE_FLAGS -Wno-unused-value)
set_source_files_properties(llurl.cpp PROPERTIES COMPILE_FLAGS
-Wno-stringop-truncation)
+ set_source_files_properties(
+ llfloaterimsessiontab.cpp
+ llfloatersimplesnapshot.cpp
+ llfloatersidepanelcontainer.cpp
+ llinventorypanel.cpp
+ llpanelmaininventory.cpp
+ llpathfindingnavmesh.cpp
+ llsidepanelinventory.cpp
+ PROPERTIES COMPILE_FLAGS -Wno-dangling-reference
+ )
endif ()
message("Copying fonts")