summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorRye Mutt <rye@alchemyviewer.org>2024-04-19 15:39:28 -0400
committerGitHub <noreply@github.com>2024-04-19 14:39:28 -0500
commite361671018068000a8b63b3cdc2ad87468def9a3 (patch)
tree89a8c8bde135e7055a01fa44e4613bf5b18893b1 /indra/newview/CMakeLists.txt
parente459698a821d14d7274fa64bcf863b47f29c1607 (diff)
Port from OpenEXR to TinyEXR for reduced installer and library size (#1287)
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 011dccb910..ed617ba70e 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -34,11 +34,11 @@ include(LLWindow)
include(NDOF)
include(NVAPI)
include(OPENAL)
-include(OpenEXR)
include(OpenGL)
include(OpenSSL)
include(PNG)
include(TemplateCheck)
+include(TinyEXR)
include(ThreeJS)
include(Tracy)
include(UI)
@@ -1750,12 +1750,6 @@ if (WINDOWS)
media_plugin_cef
media_plugin_libvlc
media_plugin_example
- ${SHARED_LIB_STAGING_DIR}/Iex-3_2.dll
- ${SHARED_LIB_STAGING_DIR}/IlmThread-3_2.dll
- ${SHARED_LIB_STAGING_DIR}/Imath-3_1.dll
- ${SHARED_LIB_STAGING_DIR}/OpenEXR-3_2.dll
- ${SHARED_LIB_STAGING_DIR}/OpenEXRCore-3_2.dll
- ${SHARED_LIB_STAGING_DIR}/OpenEXRUtil-3_2.dll
)
if (ADDRESS_SIZE EQUAL 64)
@@ -1949,7 +1943,6 @@ target_link_libraries(${VIEWER_BINARY_NAME}
ll::bugsplat
ll::tracy
ll::icu4c
- ll::openexr
)
if( TARGET ll::intel_memops )