summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Houlton <euclid@lindenlab.com>2019-11-13 16:46:27 -0700
committerDave Houlton <euclid@lindenlab.com>2019-11-13 16:46:27 -0700
commitdc1453af9c474c67749aded576c11dff3afdd444 (patch)
treebff4d5bfca6eb036339c30429ef08704d0bb68cb /indra/newview/CMakeLists.txt
parent3dfdb2f6e8be4fb2a08102847520585dc1d8fd7d (diff)
parent78bdf57ad6610b34389226bf941ba736ca0c2225 (diff)
Merge in from viewer-release 6.3.5
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index f216c3a593..98cb963de1 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1376,8 +1376,12 @@ if (DARWIN)
PROPERTIES
COMPILE_DEFINITIONS "${VIEWER_CHANNEL_VERSION_DEFINES}"
# BugsplatMac is a module, imported with @import. That language feature
- # demands these switches.
- COMPILE_FLAGS "-fmodules -fcxx-modules"
+ # demands these -f switches.
+ # Xcode 10.2 requires that Objective-C++ headers declare nullability of
+ # pointer variables. As of 2019-06-26, the BugsplatMac version we're using
+ # does not yet do so in its own header files. This -W flag prevents fatal
+ # warnings.
+ COMPILE_FLAGS "-fmodules -fcxx-modules -Wno-nullability-completeness"
)
find_library(AGL_LIBRARY AGL)