summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorGlenn Glazer <coyot@lindenlab.com>2016-05-24 11:43:57 -0700
committerGlenn Glazer <coyot@lindenlab.com>2016-05-24 11:43:57 -0700
commitce760e80c492d1c3e13306a1d06aa734b4d829a9 (patch)
tree826dd86b469182520577d538247b7fc169db0123 /indra/newview/CMakeLists.txt
parent999a949b52b50d5330c717fde19af3931e256f11 (diff)
MAINT-6413: write summary.json from viewer_manifest.py, remove facility from cmake
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rwxr-xr-xindra/newview/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 6734f62137..64b7ff34f6 100755
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1308,6 +1308,11 @@ set(viewer_HEADER_FILES
source_group("CMake Rules" FILES ViewerInstall.cmake)
#summary.json creation moved to viewer_manifest.py MAINT-6413
+# the viewer_version.txt file created here is for passing to viewer_manifest and autobuild
+add_custom_target(generate_viewer_version ALL
+ COMMAND printf '${VIEWER_SHORT_VERSION}.${VIEWER_VERSION_REVISION}' > ${CMAKE_CURRENT_BINARY_DIR}/viewer_version.txt
+ COMMENT Generating viewer_version.txt for manifest processing
+ )
set_source_files_properties(
llversioninfo.cpp tests/llversioninfo_test.cpp