summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2023-11-02 09:08:25 -0400
committerNat Goodspeed <nat@lindenlab.com>2023-11-02 09:08:25 -0400
commitbb51ead8815d6f1843bed3f16dfae94aa0e85950 (patch)
tree9b4f8911b15a36531a2d32e3550fe8744f805167 /indra/newview/CMakeLists.txt
parentcf0838cd6917b7dd2c8f056d6cb3ef9f59d92fda (diff)
DRTVWR-589: Switch to the lua package built by new 3p-lua repo.
Also ditch crufty CMake logic related to lleventhost, which we haven't used for years.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt20
1 files changed, 2 insertions, 18 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 6fc0f28a89..aa723c62cd 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1805,20 +1805,6 @@ if (WINDOWS)
if (PACKAGE)
add_custom_command(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/event_host.tar.bz2
- COMMAND ${PYTHON_EXECUTABLE}
- ARGS
- ${CMAKE_CURRENT_SOURCE_DIR}/event_host_manifest.py
- ${CMAKE_CURRENT_SOURCE_DIR}/..
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_CFG_INTDIR}
- DEPENDS
- lleventhost
- ${EVENT_HOST_SCRIPTS}
- ${CMAKE_CURRENT_SOURCE_DIR}/event_host_manifest.py
- )
-
- add_custom_command(
OUTPUT ${CMAKE_CFG_INTDIR}/touched.bat
COMMAND ${PYTHON_EXECUTABLE}
ARGS
@@ -1847,9 +1833,6 @@ if (WINDOWS)
add_custom_target(llpackage ALL DEPENDS
${CMAKE_CFG_INTDIR}/touched.bat
)
- # temporarily disable packaging of event_host until hg subrepos get
- # sorted out on the parabuild cluster...
- #${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/event_host.tar.bz2)
endif (PACKAGE)
elseif (DARWIN)
@@ -1917,6 +1900,7 @@ target_link_libraries(${VIEWER_BINARY_NAME}
${LLPHYSICSEXTENSIONS_LIBRARIES}
ll::bugsplat
ll::tracy
+ ll::lualibs
)
if( TARGET ll::intel_memops )
@@ -2287,7 +2271,7 @@ if (LL_TESTS)
LL_ADD_INTEGRATION_TEST(llluamanager
"llluamanager.cpp"
- "${test_libs}"
+ "${test_libs};ll::lualibs"
)
LL_ADD_INTEGRATION_TEST(llsechandler_basic