summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Goetze <cg@lindenlab.com>2008-07-15 01:34:41 +0000
committerChristian Goetze <cg@lindenlab.com>2008-07-15 01:34:41 +0000
commitb27e0e08f07f84e9143f51a22752ee384eedfa72 (patch)
tree204b7ff18d80a6e0d21fbf6c7c86b5f958f0b34b /indra/newview/CMakeLists.txt
parentae464867e6714816cd5bdaeecdd1d3c0a0817e58 (diff)
Add code to support add_viewer_version_to_manager
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index b2f57c8713..12085ee77e 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1325,6 +1325,7 @@ if (WINDOWS)
${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
--configuration=${CMAKE_CFG_INTDIR}
--channel=${VIEWER_CHANNEL}
+ --login_channel=${VIEWER_CHANNEL}
--grid=${GRID}
--source=${CMAKE_CURRENT_SOURCE_DIR}
--artwork=${ARTWORK_DIR}
@@ -1381,8 +1382,6 @@ build_version(viewer)
set(ARTWORK_DIR ${CMAKE_CURRENT_SOURCE_DIR} CACHE PATH
"Path to artwork files.")
-set(VIEWER_CHANNEL "Developer" CACHE STRING
- "The name of the channel to use.")
if (LINUX)
add_custom_command(
@@ -1414,6 +1413,7 @@ if (LINUX)
${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
--grid=${GRID}
--channel=${VIEWER_CHANNEL}
+ --login_channel=${VIEWER_CHANNEL}
--installer_name=${product}
--arch=${ARCH}
--source=${CMAKE_CURRENT_SOURCE_DIR}
@@ -1469,6 +1469,7 @@ if (DARWIN)
--grid=${GRID}
--configuration=${CMAKE_CFG_INTDIR}
--channel=${VIEWER_CHANNEL}
+ --login_channel=${VIEWER_CHANNEL}
--source=${CMAKE_CURRENT_SOURCE_DIR}
--artwork=${ARTWORK_DIR}
--build=${CMAKE_CURRENT_BINARY_DIR}