summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-08-21 16:32:19 +0800
committerErik Kundiman <erik@megapahit.org>2023-08-21 16:32:19 +0800
commitb1cfd19724fd1791f5b383e2d9dac71d35ba2167 (patch)
treeca36051f8e4d049a0d23165444b7feb947cd4599 /indra/newview/CMakeLists.txt
parent41a263a4ccc1171d04f289b62d879d2156b5f508 (diff)
Apple Clang doesn't recognise --as-needed
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 339ec8a623..226f9a3bda 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1425,7 +1425,9 @@ if (USESYSTEMLIBS)
COMPILE_DEFINITIONS "${VIEWER_CHANNEL_VERSION_DEFINES}"
)
#LIST(APPEND viewer_SOURCE_FILES llappviewerlinux_api_dbus.cpp)
+ if (NOT (CMAKE_CXX_COMPILER_ID MATCHES "AppleClang"))
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")
+ endif ()
endif (USESYSTEMLIBS)