summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2018-08-30 15:19:23 -0400
committerNat Goodspeed <nat@lindenlab.com>2018-08-30 15:19:23 -0400
commitaa6d178b6917af0d933dd2fdcd0c0906285b768b (patch)
treea3b894369a0e3bb2ae32944a78e37fb298bec4d6 /indra/newview/CMakeLists.txt
parent29a29db7dd154b694c1ac414ceec8e37cb745335 (diff)
SL-957: Delay trying to pack up Windows PDB file until linker done.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 36dafa52ed..10210cd918 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -2284,7 +2284,8 @@ if (PACKAGE AND (RELEASE_CRASH_REPORTING OR NON_RELEASE_CRASH_REPORTING) AND VIE
DEPENDS "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/secondlife-bin.pdb"
COMMENT "Packing viewer PDB into ${VIEWER_SYMBOL_FILE_CYGWIN}"
)
- add_custom_target(generate_symbols DEPENDS "${VIEWER_SYMBOL_FILE}")
+ add_custom_target(generate_symbols DEPENDS "${VIEWER_SYMBOL_FILE}" "${VIEWER_BINARY_NAME}")
+ add_dependencies(generate_symbols "${VIEWER_BINARY_NAME}")
endif (WINDOWS)
if (DARWIN)
# Have to run dsymutil first, then pack up the resulting .dSYM directory