summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Bennetts <steve@lindenlab.com>2008-08-12 17:29:50 +0000
committerSteven Bennetts <steve@lindenlab.com>2008-08-12 17:29:50 +0000
commit80be4c1d2d73982ea2df6dd7ef3fc3465416c882 (patch)
tree9c5958572368be494b6302db8b03967a2c67b7ad /indra/newview/CMakeLists.txt
parenta09f7d41efdb945755efaeb07f7418c1f6e2a78b (diff)
QAR-767 Combined maint-render-7 and maint-viewer-9 merge
merge release@93398 viewer-merge-1@94007 -> release dataserver-is-deprecated
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt33
1 files changed, 17 insertions, 16 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 0fea3076c3..699d13ea9b 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -159,6 +159,7 @@ set(viewer_SOURCE_FILES
llfloaterlandholdings.cpp
llfloaterlandmark.cpp
llfloatermap.cpp
+ llfloatermemleak.cpp
llfloatermute.cpp
llfloaternamedesc.cpp
llfloaternewim.cpp
@@ -549,6 +550,7 @@ set(viewer_HEADER_FILES
llfloaterlandholdings.h
llfloaterlandmark.h
llfloatermap.h
+ llfloatermemleak.h
llfloatermute.h
llfloaternamedesc.h
llfloaternewim.h
@@ -1312,10 +1314,21 @@ if (WINDOWS)
-E
copy_if_different
${CMAKE_CURRENT_SOURCE_DIR}/../../scripts/messages/message_template.msg
- ${CMAKE_CURRENT_SOURCE_DIR}/app_settings/message_template.msg
+ ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings/message_template.msg
COMMENT "Copying message_template.msg to the runtime folder."
)
+ add_custom_command(
+ TARGET secondlife-bin PRE_BUILD
+ COMMAND ${CMAKE_COMMAND}
+ ARGS
+ -E
+ copy_if_different
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../etc/message.xml
+ ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings/message.xml
+ COMMENT "Copying message.xml to the runtime folder."
+ )
+
add_dependencies(secondlife-bin copy_win_libs)
if (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts)
@@ -1389,25 +1402,12 @@ set(ARTWORK_DIR ${CMAKE_CURRENT_SOURCE_DIR} CACHE PATH
if (LINUX)
add_custom_command(
- OUTPUT secondlife-stripped-globalsyms
+ OUTPUT secondlife-stripped
COMMAND strip
- ARGS --strip-debug -o secondlife-stripped-globalsyms secondlife-bin
+ ARGS --strip-debug -o secondlife-stripped secondlife-bin
DEPENDS secondlife-bin
)
- add_custom_command(
- OUTPUT secondlife-stripped
- COMMAND objcopy
- ARGS
- --keep-global-symbols
- ${CMAKE_CURRENT_SOURCE_DIR}/linux_tools/exposed-symbols.txt
- secondlife-stripped-globalsyms
- secondlife-stripped
- DEPENDS
- secondlife-stripped-globalsyms
- ${CMAKE_CURRENT_SOURCE_DIR}/linux_tools/exposed-symbols.txt
- )
-
set(product SecondLife-${ARCH}-${viewer_VERSION})
add_custom_command(
@@ -1483,6 +1483,7 @@ if (DARWIN)
secondlife-bin
${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
)
+ add_dependencies(package mac-updater mac-crash-logger)
endif (PACKAGE)
endif (DARWIN)