summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Lihatskiy <alihatskiy@productengine.com>2020-08-06 15:23:12 +0300
committerAndrey Lihatskiy <alihatskiy@productengine.com>2020-08-06 15:26:11 +0300
commit77c629e0251cf5b5a65077ec6a0697555f7be70a (patch)
treedc085d76f23ed93bf260e941ddac301e9cadb4a7 /indra/newview/CMakeLists.txt
parent6077f296dd7c23b188dd4813636f7b2b83658b96 (diff)
Revert "SL-13082 Declare macOS SDK version to be 10.12 instead of 10.15"
This reverts commit 7d4b1c014c9900af47005a529df50ece14249326. Until the TC mac build nodes update.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index a17bf088cd..0d204fd716 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1944,10 +1944,6 @@ elseif (DARWIN)
set_target_properties(${VIEWER_BINARY_NAME}
PROPERTIES
LINK_FLAGS_RELEASE "${LINK_FLAGS_RELEASE} -Xlinker -dead_strip -Xlinker -map -Xlinker ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_BINARY_NAME}.MAP"
- # Force the SDK version in the linked executable to be 10.12. This will fool
- # macOS into using the pre-Mojave display system, avoiding the blurry display that
- # otherwise occurs when upscaling the viewer to Retina resolution levels.
- LINK_FLAGS_RELEASE "${LINK_FLAGS_RELEASE} -Xlinker -platform_version -Xlinker macos -Xlinker ${CMAKE_OSX_DEPLOYMENT_TARGET} -Xlinker 10.12"
)
else (WINDOWS)
# Linux