summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-08-21 15:27:51 +0800
committerErik Kundiman <erik@megapahit.org>2023-08-21 15:27:51 +0800
commit6da23f151be1ce7ad98912b504ef4dbcb0cdd494 (patch)
treeae2534631d44e51a150991b4531cdddcbd1bc0cc /indra/newview/CMakeLists.txt
parenteccb10575d3b6dc841cf4bf07db29833174d1c69 (diff)
Revert "FreeBSD can use llappviewerlinux too"
This reverts commit 8356386f6674cf7f1e25bcd49f3266868cd5dc7d.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 48c9462f9f..a4e40d0959 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1413,7 +1413,7 @@ if (DARWIN)
list(APPEND viewer_SOURCE_FILES ${viewer_RESOURCE_FILES})
endif (DARWIN)
-if (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+if (LINUX)
LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp)
set_source_files_properties(
llappviewerlinux.cpp
@@ -1423,7 +1423,7 @@ if (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
LIST(APPEND viewer_SOURCE_FILES llappviewerlinux_api_dbus.cpp)
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")
-endif (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+endif (LINUX)
if (WINDOWS)
list(APPEND viewer_SOURCE_FILES