summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Antipov <mantipov@productengine.com>2010-05-21 13:16:29 +0300
committerMike Antipov <mantipov@productengine.com>2010-05-21 13:16:29 +0300
commit5c370550bf216c24841879b5041f9b9d40fb459c (patch)
tree249ab1c7eba580b22380805dc816217a430d8ba3 /indra/newview/CMakeLists.txt
parentc3a352b219380faa722be6f1ac916a7b95eb836c (diff)
EXT-6710 WIP Prepare to implementation - "Give inventory" related functionality was moved from the LLToolDragAndDrop to a separate class - LLGiveInventory.
To allow give several inventory items to several selected residents I need some functionality encapsulated in LLToolDragAndDrop class out of it. No functionality should be changed. LLToolDragAndDrop was updated to use new LLGiveInventory'methods instead of removed ones. There were moved methods related to: - give inventory item - give inventory category - log into chat Such functionality was moved: - is give acceptable - do inventory give operation - send give inventory request to server - process give inventory for protected items QA Notes: Functionality related to give inventory via drag and drop should be re-tested closely. Reviewed by Richard Nelson at https://codereview.productengine.com/secondlife/r/364/ --HG-- branch : product-engine
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index d77d53f6af..df98b420a2 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -224,6 +224,7 @@ set(viewer_SOURCE_FILES
llfollowcam.cpp
llfriendcard.cpp
llgesturemgr.cpp
+ llgiveinventory.cpp
llglsandbox.cpp
llgroupactions.cpp
llgroupiconctrl.cpp
@@ -740,6 +741,7 @@ set(viewer_HEADER_FILES
llfollowcam.h
llfriendcard.h
llgesturemgr.h
+ llgiveinventory.h
llgroupactions.h
llgroupiconctrl.h
llgrouplist.h