summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Polunin <apolunin@gmail.com>2010-06-03 18:59:16 +0300
committerAndrew Polunin <apolunin@gmail.com>2010-06-03 18:59:16 +0300
commit5609f78f456a2919aa6eba76955a2438689c0689 (patch)
treec40dde84f6e72ec52e82872be6ddbcfa2f8bfb7a /indra/newview/CMakeLists.txt
parent68d729dfe2c63a931c52b0f49a92bf18a270ff52 (diff)
EXT-5808 FIXED Mini-Location panel was added below Navigation Bar
- Implemented class LLPanelTopInfoBar (llpaneltopinfobar.h, llpaneltopinfobar.cpp, panel_topinfo_bar.xml). Most of it's implementation is borrowed from LLLocationInputCtrl class. - Mini-Location panel is turned off by default. - Added top bar context menu option \"Show Mini-Location Panel\". - Mini-Location panel displays the same context menu as top bar. - Added code to initialize LLPanelTopInfoBar in llviewerwindow.cpp. - Added declaration of the widget in main_view.xml Reviewed by Mike Antipov at https://codereview.productengine.com/secondlife/r/464/ --HG-- branch : product-engine
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index b00104c427..7dbe650625 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -356,6 +356,7 @@ set(viewer_SOURCE_FILES
llpanelprofileview.cpp
llpanelteleporthistory.cpp
llpaneltiptoast.cpp
+ llpaneltopinfobar.cpp
llpanelvolume.cpp
llpanelvolumepulldown.cpp
llparcelselection.cpp
@@ -871,6 +872,7 @@ set(viewer_HEADER_FILES
llpanelprofileview.h
llpanelteleporthistory.h
llpaneltiptoast.h
+ llpaneltopinfobar.h
llpanelvolume.h
llpanelvolumepulldown.h
llparcelselection.h