summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorbrad kittenbrink <brad@lindenlab.com>2009-09-04 19:53:51 -0400
committerbrad kittenbrink <brad@lindenlab.com>2009-09-04 19:53:51 -0400
commit2ecd2689808ca0de4eb80d2e1459bf09d2499ea7 (patch)
treeb64c2a699b22c8486617e30118c1da8652ea92c6 /indra/newview/CMakeLists.txt
parent369f5ba524e7ad7760b2e367ad336d09d129733e (diff)
Fix for SLPlugin.exe packaging failure. Still needs some cleanup though.
qtwebkit4.dll etc aren't being staged to the sharedlibs dir like everything else.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 3239fbf84e..cae6a79ec8 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -1621,6 +1621,16 @@ LL_ADD_INTEGRATION_TEST(llcapabilitylistener
# Don't do these for DARWIN or LINUX here -- they're taken care of by viewer_manifest.py
if (WINDOWS)
+ add_custom_command(
+ TARGET ${VIEWER_BINARY_NAME} POST_BUILD
+ COMMAND ${CMAKE_COMMAND}
+ ARGS
+ -E
+ make_directory
+ ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin
+ COMMENT "Creating llplugin dir."
+ )
+
get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION)
add_custom_command(
TARGET ${VIEWER_BINARY_NAME} POST_BUILD