summaryrefslogtreecommitdiff
path: root/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2024-07-05 11:00:42 +0800
committerErik Kundiman <erik@megapahit.org>2024-07-05 11:00:42 +0800
commit0627bb28339ffc678ca93e823d844407134d8aa1 (patch)
tree72641117e205d705d8ca97119112f6d67941c95e /indra/newview/CMakeLists.txt
parent765a0ceb6b1ab3123a9f2782fb8e73fb3c2e7732 (diff)
macOS viewer_manifest.py not run if INSTALL is ON
`make install` instead should do the job. Some generations haven't been reimplemented, including build_data.json, contributors.txt, and settings_install.xml.
Diffstat (limited to 'indra/newview/CMakeLists.txt')
-rw-r--r--indra/newview/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/newview/CMakeLists.txt b/indra/newview/CMakeLists.txt
index 8070cd0796..4b0c9b1886 100644
--- a/indra/newview/CMakeLists.txt
+++ b/indra/newview/CMakeLists.txt
@@ -2167,6 +2167,7 @@ if (DARWIN)
"${VIEWER_APP_BUNDLE}/Contents/Info.plist"
)
+ if (NOT INSTALL)
add_custom_command(
TARGET ${VIEWER_BINARY_NAME} POST_BUILD
COMMAND ${PYTHON_EXECUTABLE}
@@ -2191,6 +2192,7 @@ if (DARWIN)
${VIEWER_BINARY_NAME}
${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
)
+ endif (NOT INSTALL)
if (ENABLE_MEDIA_PLUGINS)
if (DARWIN OR LINUX)