summaryrefslogtreecommitdiff
path: root/indra/media_plugins/webkit/CMakeLists.txt
diff options
context:
space:
mode:
authorTofu Linden <tofu.linden@lindenlab.com>2010-04-19 14:30:43 +0100
committerTofu Linden <tofu.linden@lindenlab.com>2010-04-19 14:30:43 +0100
commitf28a9b3ca52978772e2963f4610a1bab1f1e9cee (patch)
treeb0c4a68d3260a01845c8d94b66e93efbd6b102b8 /indra/media_plugins/webkit/CMakeLists.txt
parent186224ab91e53c712537887f3d08293520338250 (diff)
parent532d732645f2369d17eba9c2ed0d594b486d416e (diff)
merge from viewer-trunk
Diffstat (limited to 'indra/media_plugins/webkit/CMakeLists.txt')
-rw-r--r--indra/media_plugins/webkit/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/indra/media_plugins/webkit/CMakeLists.txt b/indra/media_plugins/webkit/CMakeLists.txt
index 4f183cddeb..1a559ed39c 100644
--- a/indra/media_plugins/webkit/CMakeLists.txt
+++ b/indra/media_plugins/webkit/CMakeLists.txt
@@ -36,6 +36,10 @@ set(media_plugin_webkit_SOURCE_FILES
media_plugin_webkit.cpp
)
+set(media_plugin_webkit_HEADER_FILES
+ volume_catcher.h
+ )
+
set(media_plugin_webkit_LINK_LIBRARIES
${LLPLUGIN_LIBRARIES}
${MEDIA_PLUGIN_BASE_LIBRARIES}
@@ -59,11 +63,18 @@ elseif (DARWIN)
${CORESERVICES_LIBRARY} # for Component Manager calls
${AUDIOUNIT_LIBRARY} # for AudioUnit calls
)
+elseif (WINDOWS)
+ list(APPEND media_plugin_webkit_SOURCE_FILES windows_volume_catcher.cpp)
else (LINUX AND PULSEAUDIO)
# All other platforms use the dummy volume catcher for now.
list(APPEND media_plugin_webkit_SOURCE_FILES dummy_volume_catcher.cpp)
endif (LINUX AND PULSEAUDIO)
+set_source_files_properties(${media_plugin_webkit_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND media_plugin_webkit_SOURCE_FILES ${media_plugin_webkit_HEADER_FILES})
+
add_library(media_plugin_webkit
SHARED
${media_plugin_webkit_SOURCE_FILES}