summaryrefslogtreecommitdiff
path: root/indra/media_plugins/webkit/CMakeLists.txt
diff options
context:
space:
mode:
authorMonroe Linden <monroe@lindenlab.com>2010-04-09 12:34:24 -0700
committerMonroe Linden <monroe@lindenlab.com>2010-04-09 12:34:24 -0700
commitdb3641363d9b9d1dcf31a54897d24c65225155c2 (patch)
tree2c392ad0c4d2d7cf5202ebb37d53e385aba00f58 /indra/media_plugins/webkit/CMakeLists.txt
parent0da8fb6035f69399468f0085cd967f90efa91c40 (diff)
Set up volume control code in webkit plugin for platform-specific implementations
Renamed LinuxVolumeCatcher class to VolumeCatcher. Everything in the header except the class name was already platform-agnostic, so I just renamed it to volume_catcher.h. Moved the stub implementation from the end of linux_volume_catcher.cpp (previously only used if LL_PULSEAUDIO_ENABLED was not defined) to dummy_volume_catcher.cpp, and made CMakeList.txt file use the dummy impl on Linux if PULSEAUDIO is not defined. Removed the ifdefs on the use of VolumeCatcher in MediaPluginWebkit, so it gets called on all platforms. Added a setPan() function to VolumeCatcher (currently unimplemented, but we'd like to have this capability in the future).
Diffstat (limited to 'indra/media_plugins/webkit/CMakeLists.txt')
-rw-r--r--indra/media_plugins/webkit/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/indra/media_plugins/webkit/CMakeLists.txt b/indra/media_plugins/webkit/CMakeLists.txt
index 9f66a77c64..c3a3f8e2b2 100644
--- a/indra/media_plugins/webkit/CMakeLists.txt
+++ b/indra/media_plugins/webkit/CMakeLists.txt
@@ -45,12 +45,16 @@ set(media_plugin_webkit_LINK_LIBRARIES
${PULSEAUDIO_LIBRARIES}
)
-if (LINUX)
+# Select which VolumeCatcher implementation to use
+if (LINUX AND PULSEAUDIO)
list(APPEND media_plugin_webkit_SOURCE_FILES linux_volume_catcher.cpp)
list(APPEND media_plugin_webkit_LINK_LIBRARIES
${UI_LIBRARIES} # for glib/GTK
)
-endif (LINUX)
+else (LINUX AND PULSEAUDIO)
+ # All other platforms use the dummy volume catcher for now.
+ list(APPEND media_plugin_webkit_SOURCE_FILES dummy_volume_catcher.cpp)
+endif (LINUX AND PULSEAUDIO)
add_library(media_plugin_webkit
SHARED