summaryrefslogtreecommitdiff
path: root/indra/media_plugins/libvlc/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-12-18 20:42:30 +0800
committerErik Kundiman <erik@megapahit.org>2023-12-18 20:42:30 +0800
commitb0e28d27bd990393e22ca3f474c340e77a08357b (patch)
tree31698ce16af0883d128cb4cc804c25f85650c711 /indra/media_plugins/libvlc/CMakeLists.txt
parentee89162c037d693d63376762b417049f5f066672 (diff)
Unix install sets plugin dir to system library dir
because (at least) the vlc/plugins dirs are inside it in the same way it's been inside llplugin. This is so the app can find system VLC plugins. And for this, BUILD_SHARED_LIBS set on must work first on Linux (has already been working on FreeBSD), since libmedia_plugin_libvlc is a shared library (which now gets installed to system library dir too, on both OSes).
Diffstat (limited to 'indra/media_plugins/libvlc/CMakeLists.txt')
-rw-r--r--indra/media_plugins/libvlc/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/indra/media_plugins/libvlc/CMakeLists.txt b/indra/media_plugins/libvlc/CMakeLists.txt
index 84fac1634c..9e5c0abb62 100644
--- a/indra/media_plugins/libvlc/CMakeLists.txt
+++ b/indra/media_plugins/libvlc/CMakeLists.txt
@@ -56,7 +56,4 @@ if (DARWIN)
endif (DARWIN)
-if (INSTALL)
- install(TARGETS ${PROJECT_NAME} DESTINATION
- libexec/${VIEWER_BINARY_NAME}/llplugin)
-endif ()
+include(LibraryInstall)