summaryrefslogtreecommitdiff
path: root/indra/media_plugins/example/CMakeLists.txt
diff options
context:
space:
mode:
authorLoren Shih <seraph@lindenlab.com>2010-10-13 17:08:00 -0400
committerLoren Shih <seraph@lindenlab.com>2010-10-13 17:08:00 -0400
commitded6a78541d9f779b5cbef0d1255588b93d5dce6 (patch)
treef343cacbfd01888c604b891ceb877b429f50641c /indra/media_plugins/example/CMakeLists.txt
parentfa20a3fe100bd2c99b6fe4c087c79268752a107c (diff)
parentc7c43d83f80dcac8be79cc76c9d9bbf8ff4c8354 (diff)
Automated merge up from viewer-development
Diffstat (limited to 'indra/media_plugins/example/CMakeLists.txt')
-rw-r--r--indra/media_plugins/example/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/media_plugins/example/CMakeLists.txt b/indra/media_plugins/example/CMakeLists.txt
index 4d82f2747c..56cefde4bd 100644
--- a/indra/media_plugins/example/CMakeLists.txt
+++ b/indra/media_plugins/example/CMakeLists.txt
@@ -29,6 +29,14 @@ include_directories(
### media_plugin_example
+if(NOT WORD_SIZE EQUAL 32)
+ if(WINDOWS)
+ add_definitions(/FIXED:NO)
+ else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
+ add_definitions(-fPIC)
+ endif(WINDOWS)
+endif(NOT WORD_SIZE EQUAL 32)
+
set(media_plugin_example_SOURCE_FILES
media_plugin_example.cpp
)