summaryrefslogtreecommitdiff
path: root/indra/media_plugins/example/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2010-10-12 10:59:43 -0400
committerOz Linden <oz@lindenlab.com>2010-10-12 10:59:43 -0400
commit8269d4d51cd58fa5c8fc4ac22d9f42041849889d (patch)
treebe56c82c01f3b4e10ad2a38a2d2f8f9939f62a3b /indra/media_plugins/example/CMakeLists.txt
parent8b55caf9767777c2bfd578cba22f220b2c2c21be (diff)
parent28d8612cf767d42a15c6cc8ee030bdcfab496987 (diff)
pull fixes for STORM-368 (enable LL_TESTS on all tests)
Diffstat (limited to 'indra/media_plugins/example/CMakeLists.txt')
-rw-r--r--indra/media_plugins/example/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/media_plugins/example/CMakeLists.txt b/indra/media_plugins/example/CMakeLists.txt
index 4d82f2747c..56cefde4bd 100644
--- a/indra/media_plugins/example/CMakeLists.txt
+++ b/indra/media_plugins/example/CMakeLists.txt
@@ -29,6 +29,14 @@ include_directories(
### media_plugin_example
+if(NOT WORD_SIZE EQUAL 32)
+ if(WINDOWS)
+ add_definitions(/FIXED:NO)
+ else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
+ add_definitions(-fPIC)
+ endif(WINDOWS)
+endif(NOT WORD_SIZE EQUAL 32)
+
set(media_plugin_example_SOURCE_FILES
media_plugin_example.cpp
)