summaryrefslogtreecommitdiff
path: root/indra/media_plugins/cef/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2024-12-31 18:13:54 +0800
committerErik Kundiman <erik@megapahit.org>2024-12-31 18:18:17 +0800
commitfc3c0f48d92bf9c3dcad622b2b8e9340edc92c7c (patch)
treed913bcdc43062763f34160816ab8c5457caac3d2 /indra/media_plugins/cef/CMakeLists.txt
parent26974d238ce5ba5a3c22b8788b6754d5911c06c2 (diff)
Decide lib64 or x86_64-linux-gnu based on distro
Some builders might just have their installation somehow customised to have both.
Diffstat (limited to 'indra/media_plugins/cef/CMakeLists.txt')
-rw-r--r--indra/media_plugins/cef/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/indra/media_plugins/cef/CMakeLists.txt b/indra/media_plugins/cef/CMakeLists.txt
index 3799fa41ac..007b74eda7 100644
--- a/indra/media_plugins/cef/CMakeLists.txt
+++ b/indra/media_plugins/cef/CMakeLists.txt
@@ -143,13 +143,13 @@ if (INSTALL)
DESTINATION SLPlugin.app/Contents/Frameworks
)
elseif (LINUX)
- if (EXISTS ${CMAKE_SYSROOT}/usr/lib/${ARCH}-linux-gnu)
+ if (${LINUX_DISTRO} MATCHES debian OR (${LINUX_DISTRO} MATCHES ubuntu))
set(_LIB lib/${ARCH}-linux-gnu)
- elseif (EXISTS /lib64 AND NOT ${LINUX_DISTRO} MATCHES arch)
- set(_LIB lib64)
- else (EXISTS ${CMAKE_SYSROOT}/usr/lib/${ARCH}-linux-gnu)
+ elseif (${LINUX_DISTRO} MATCHES fedora OR (${LINUX_DISTRO} MATCHES opensuse-tumbleweed))
+ set(_LIB lib${ADDRESS_SIZE})
+ else ()
set(_LIB lib)
- endif (EXISTS ${CMAKE_SYSROOT}/usr/lib/${ARCH}-linux-gnu)
+ endif ()
if (${LINUX_DISTRO} MATCHES arch)
install(
PROGRAMS