summaryrefslogtreecommitdiff
path: root/indra/media_plugins/cef/CMakeLists.txt
diff options
context:
space:
mode:
authorRider Linden <rider@lindenlab.com>2016-01-20 16:08:33 -0800
committerRider Linden <rider@lindenlab.com>2016-01-20 16:08:33 -0800
commit28921896f18eaf51583ffac1f29fbae2d227ab8b (patch)
tree9fe19583e2f0661cc67c14798e4ce08a5a84df76 /indra/media_plugins/cef/CMakeLists.txt
parentf51a240755a22c904f177d80bb76136a5f3e72c8 (diff)
OPEN-312: Removed add_dependency entries for items listed in target_link_libraries. Superfluous.
Diffstat (limited to 'indra/media_plugins/cef/CMakeLists.txt')
-rw-r--r--indra/media_plugins/cef/CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/indra/media_plugins/cef/CMakeLists.txt b/indra/media_plugins/cef/CMakeLists.txt
index 1f6163e41e..07b5af819e 100644
--- a/indra/media_plugins/cef/CMakeLists.txt
+++ b/indra/media_plugins/cef/CMakeLists.txt
@@ -2,6 +2,7 @@
project(media_plugin_cef)
+include(Boost)
include(00-Common)
include(LLCommon)
include(LLImage)
@@ -52,8 +53,8 @@ set(media_plugin_cef_HEADER_FILES
set (media_plugin_cef_LINK_LIBRARIES
${LLPLUGIN_LIBRARIES}
${MEDIA_PLUGIN_BASE_LIBRARIES}
- ${LLCOMMON_LIBRARIES}
${CEF_PLUGIN_LIBRARIES}
+ ${LLCOMMON_LIBRARIES}
${PLUGIN_API_WINDOWS_LIBRARIES})
@@ -84,11 +85,9 @@ add_library(media_plugin_cef
${media_plugin_cef_SOURCE_FILES}
)
-add_dependencies(media_plugin_cef
- ${LLPLUGIN_LIBRARIES}
- ${MEDIA_PLUGIN_BASE_LIBRARIES}
- ${LLCOMMON_LIBRARIES}
-)
+#add_dependencies(media_plugin_cef
+# ${MEDIA_PLUGIN_BASE_LIBRARIES}
+#)
target_link_libraries(media_plugin_cef
${media_plugin_cef_LINK_LIBRARIES}