summaryrefslogtreecommitdiff
path: root/indra/media_plugins/cef/CMakeLists.txt
diff options
context:
space:
mode:
authorMaki <maki@hotmilk.space>2024-04-17 23:06:29 -0400
committerMaki <maki@hotmilk.space>2024-04-17 23:06:29 -0400
commit1e5b77547fd4a70888ab24834bfdb634206cafc3 (patch)
tree4d32017ffc78b955992dc65da43ba0f79e986e59 /indra/media_plugins/cef/CMakeLists.txt
parent7d2608947ccfa2215fa66d162134bf67bf27b383 (diff)
Use PipeWire for Linux volume catcher
Diffstat (limited to 'indra/media_plugins/cef/CMakeLists.txt')
-rw-r--r--indra/media_plugins/cef/CMakeLists.txt26
1 files changed, 15 insertions, 11 deletions
diff --git a/indra/media_plugins/cef/CMakeLists.txt b/indra/media_plugins/cef/CMakeLists.txt
index bbd2eb222a..9e129f2185 100644
--- a/indra/media_plugins/cef/CMakeLists.txt
+++ b/indra/media_plugins/cef/CMakeLists.txt
@@ -24,17 +24,21 @@ set(media_plugin_cef_HEADER_FILES
# Select which VolumeCatcher implementation to use
if (LINUX)
- foreach( PULSE_FILE pulse/introspect.h pulse/context.h pulse/subscribe.h pulse/glib-mainloop.h )
- find_path( PULSE_FILE_${PULSE_FILE}_FOUND ${PULSE_FILE} NO_CACHE)
- if( NOT PULSE_FILE_${PULSE_FILE}_FOUND )
- message( "Looking for ${PULSE_FILE} ... not found")
- message( FATAL_ERROR "Pulse header not found" )
- else()
- message( "Looking for ${PULSE_FILE} ... found")
- endif()
- endforeach()
- message( "Building with linux volume catcher" )
- set(LINUX_VOLUME_CATCHER linux_volume_catcher.cpp)
+ # foreach( PULSE_FILE pulse/introspect.h pulse/context.h pulse/subscribe.h pulse/glib-mainloop.h )
+ # find_path( PULSE_FILE_${PULSE_FILE}_FOUND ${PULSE_FILE} NO_CACHE)
+ # if( NOT PULSE_FILE_${PULSE_FILE}_FOUND )
+ # message( "Looking for ${PULSE_FILE} ... not found")
+ # message( FATAL_ERROR "Pulse header not found" )
+ # else()
+ # message( "Looking for ${PULSE_FILE} ... found")
+ # endif()
+ # endforeach()
+
+ include(FindPipeWire)
+ include_directories(SYSTEM ${PIPEWIRE_INCLUDE_DIRS} ${SPA_INCLUDE_DIRS})
+
+ message( "Building with Linux volume catcher using PipeWire" )
+ set(LINUX_VOLUME_CATCHER linux_volume_catcher_pw.cpp)
list(APPEND media_plugin_cef_SOURCE_FILES ${LINUX_VOLUME_CATCHER})
set(CMAKE_SHARED_LINKER_FLAGS "-Wl,--build-id -Wl,-rpath,'$ORIGIN:$ORIGIN/../../lib'")