summaryrefslogtreecommitdiff
path: root/indra/media_plugins/cef/CMakeLists.txt
diff options
context:
space:
mode:
authorcallum@lindenlab.com <callum@lindenlab.com>2017-02-24 15:44:36 -0800
committercallum@lindenlab.com <callum@lindenlab.com>2017-02-24 15:44:36 -0800
commit08940da90ee944dd838b1db65658c39bb0aa80d4 (patch)
treea137f0c8dd9a993d6cf2e9f83cf36d1f0dec838c /indra/media_plugins/cef/CMakeLists.txt
parentbff83a7f415635cf575520bc747e5da7a5b1ef0f (diff)
First round of changes to make the macOS 64 build work
Diffstat (limited to 'indra/media_plugins/cef/CMakeLists.txt')
-rw-r--r--indra/media_plugins/cef/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/indra/media_plugins/cef/CMakeLists.txt b/indra/media_plugins/cef/CMakeLists.txt
index 1c41fadcaf..bc924eabf0 100644
--- a/indra/media_plugins/cef/CMakeLists.txt
+++ b/indra/media_plugins/cef/CMakeLists.txt
@@ -93,6 +93,9 @@ if (DARWIN)
LINK_FLAGS "-exported_symbols_list ${CMAKE_CURRENT_SOURCE_DIR}/../base/media_plugin_base.exp"
)
+ ## turns on C++11 using Cmake
+ target_compile_features(media_plugin_cef PRIVATE cxx_range_for)
+
add_custom_command(TARGET media_plugin_cef
POST_BUILD COMMAND ${CMAKE_INSTALL_NAME_TOOL} -change "@executable_path/Chromium Embedded Framework"
"@executable_path/../../../../Frameworks/Chromium Embedded Framework.framework/Chromium Embedded Framework"